Wednesday, August 22, 2012

PNA Removed from Citrix Receiver 3.3

Citrix are really trying to push StoreFront to their customers.  Since Citrix client 13 they have packaged the "plugin" into Citrix Receiver. 

Receiver is the framework in which plugins (Online, Offline (streamed), SSO (password manager) etc.) were managed by.  As users frequently just installed the Online Plugin it was confusing that the client needed for other operating systems was called Receiver.

Citrix decided to just go ahead and force users to use Receiver for Windows and make the Online Plugin a default addition thus making the naming consistent across the board.

This was ok on the whole, but since version 3.3 they have made a prompt which asks users for the URL for Citrix Storefront.  This does not accept a PNA web address and can be throughly confusing to users who are using a standard Web Interface to launch their applications!

The string provided in my earlier blog post still works to remove the receiver branding and popup, but it is not like end-users will install the software like this on their own PCs.

http://www.teamas.co.uk/2011/09/citrix-online-plugin-13.html

If you still want to use PNA you need to download a different version of receiver (receiver 3.3 Legacy PNA).  This can be found at the following website (MyCitrix login required)

https://www.citrix.com/English/SS/downloads/details.asp?downloadId=2327681&productId=1689163#top

If you do a basic install, it will not provide the old blue bubble in the system tray and will only show applications in the start menu.  To make it install like it did from the good old days use the installation string as follows

CitrixReceiverEnterprise.exe /silent ADDLOCAL="ICA_Client,SSON,USB,DesktopViewer,Flash,PN_Agent,Vd3d" ENABLE_SSON="Yes"

16 comments:

  1. Many thanks, just what i was looking for.

    ReplyDelete
    Replies
    1. No problem, how did you come across the post?

      Delete
  2. Thank you! Very confusing that this info isnt available from Citrix, tried forever to get the blue bubble .. so thank you!!!

    ReplyDelete
  3. Thanks Sam, this helped me a great deal the other day. Do you know if this will also apply to the latest Citrix Receiver 3.4 Legacy PNA?

    Cheers,
    Dan

    ReplyDelete
    Replies
    1. Good to know. I haven't tried this on Citrix Receiver 3.4 yet, but I suspect it will work the same. It doesn't look like they have changed it much. I will try it out later on.

      Delete
  4. It works the same...

    ReplyDelete
    Replies
    1. But with Citrix Receiver 3.4 you only get the Online Plugin 13.4.0.25.

      Delete
  5. This is awesome thanks so much for this info. I really dislike how Citrix is going away from the PNA type connections. I have no need or desire to setup a provisioning application server.

    Question on this install. Is there still a switch to enter a secondary URL path incase the primary is down?

    ReplyDelete
    Replies
    1. read this article http://support.citrix.com/article/CTX122973

      Delete
  6. Hi Sam,
    Thanks for this, however this doesnt seem to work with latest Citrix Receiver 3.4, any options or changes to the new one?

    Regards,
    Marsh

    ReplyDelete
    Replies
    1. Hi

      PNA has been removed from the standard receiver from 3.3 onwards. To get PNA working you need a separate download. for 3.4 you need this link http://www.citrix.co.uk/downloads/citrix-receiver/legacy-client-software/receiver-for-windows-34-enterprise.html

      follow the same instructions as above and it will work.

      CitrixReceiverEnterprise.exe /silent ADDLOCAL="ICA_Client,SSON,USB,DesktopViewer,Flash,PN_Agent,Vd3d" ENABLE_SSON="Yes"

      Delete
  7. Has anyone had issues with the actual performance of the receiver /online plugin using 3.4/13.4. I downloaded the citrixreceiverenterprise.exe (legacy PNA)3.4 version and just did a straight install by double clicking and all seems to work (including letting me launch apps from the traditional blue systray icon) but it runs like an abolsute dog and takes about 10 mins from loading to eventually launching my first published app.

    ReplyDelete
    Replies
    1. Problem seems to have been solved.
      I first tried going back a version to 3.3 and using your install string and that all seemed to work fine so then uninstalled and did the same thing using the 3.4 exe and all now working fine on both Windows 7 & XP machines.

      Seems just double clicking the install exe was the cause of all my issues!?

      Excellent! Surprised it was so difficult find clear guidance on this until I found you post.

      Delete
    2. Hi Rico

      We were preparing to install 3.4 receiver (plugin 13.4) onto our production farm but saw the same performance issues you mentioned, even when installed silently. We found this only occurred when connecting to Citrix sessions to our old PS4 servers. Connecting to XenApp 6 was absolutely fine. I noticed Citrix have not removed 3.3 from their website, which might suggest a bug with 3.4. Anyway, I will write a separate blog entry for this.

      Sam

      Delete
    3. New blogpost

      http://www.teamas.co.uk/2013/07/poor-performance-of-citrix-receiver-34.html

      Delete
  8. I would like to remove citrix online plug-in (PNA. It lets me remove all of the other Citrix components, but not the 02 version. How can I accomplish this?

    ReplyDelete