Monday, July 27, 2015

Workspace Control doesn't work

Workspace control is a feature of Citrix where users are able to seamlessly reconnect to their active or disconnected sessions from other devices.  It is part of a wider feature set called Smooth Roaming which has been part of ICA for a number of years.

Recently I found that our production Citrix Access Gateway environment stopped supporting Workspace Control.  Users who became disconnected from their desktop session were unable to reconnect to that same session because it was "active" between the CAG and the XenApp box.  It meant that admins had to disconnect the session and on next desktop launch it would reconnect.

The other thing to note is that Citrix built a couple of buttons to handle these actions manually.  They showed underneath the Logon button in Web Interface.

Broken!

Fixed!

These buttons only show up in Internet Explorer and if the WI site is in Trusted Sites or the specific setting you need to DISABLE is

"Only allow approved domains to use activeX without prompting"

At this point I will acknowledge that using WI 5.4 and CAG 5.4 is pretty old school and an upgrade is being designed, but for those living in the real world and can't just upgrade willy nilly (especially given the fact StoreFront has had some serious issues) WI 5.4 is still pretty important.

So why did it stop working all of a sudden?

Well I don't know, my gut feel is that Microsoft have updated IE11 or a core component.  But I have a workaround.  If you put the WI site into compatibility view mode, the disconnect/reconnect buttons show up and Workspace Control automatically reconnects your sessions on logon (as long as your settings in WI cater for it).

Tools > Compatibility View settings

The user is also then able to configure their own settings too.

Broken!

Fixed!
Hopefully this workaround will relieve your admins whilst you upgrade to Storefront etc.

Sam