Wednesday, July 03, 2013

Poor Performance of Citrix Receiver 3.4

My company are in the process of upgrading our Citrix XenApp image to include hotfixes and new versions of software for Flash, Reader and the Citrix Online plugin.

Currently we use plugin 12.1 which works pretty well overall.  The only real issue we see with this is connecting to other companies access gateway infrastructure if they are using Web Interface 5.3 using IE9.  We have a workaround for this, but fixing the problem would allow us to ditch a couple of servers.

http://support.citrix.com/article/CTX126653

So we planned to upgrade the plugin to the latest version which supports PNA.  Version 3.4 is the latest versions available to download from the Citrix website.

http://www.citrix.co.uk/downloads/citrix-receiver/legacy-client-software/receiver-for-windows-34-enterprise.html

We installed it using the string I have discussed numerous times on this site.  This ensured that the receiver element was at a minimum.

http://www.teamas.co.uk/2012/08/pna-remove-from-citrix-33.html

We tested this for a while and noticed that performance to Citrix XenApp application based on XenApp 6.0 was great, but when connecting to our old farm which is based on Citrix Presentation Server 4.0 the performance was awful!  The screen refresh was incredibly slow, mouse clicks wouldn't register and overall it wasn't acceptable.

We decided to install the previous version (3.3) which is still available on the Citrix website.  This is unusual, typically software vendors remove old versions of software when a new release has arrived.  This could suggest there is a known issue with 3.4.

http://www.citrix.co.uk/downloads/citrix-receiver/legacy-client-software/receiver-for-windows-33-legacy-pna.html

Once 3.3 was installed, performance to both our farms was perfect!

So if you have installed version 3.4 and are having performance problems check out a downgrade and let me know how you get on.

Thanks
Sam